Back

How do I merge two family trees?

It is possible to merge two family tree projects using Family Tree Builder software.

Trees will be merged during Import GEDCOM process (click here to learn what a GEDCOM file is) in Family Tree Builder. The first tree will be used as a basis for merge, and the second tree will be merged with the basic project.

You will have to take different actions depending on where you originally created the family trees that you would like to merge.

If both projects were created online:

- If you don’t have Family Tree Builder on your computer, download it for free here.

- Export each of two projects to GEDCOM file from your online family site(s):  Can I export a GEDCOM file of my family tree on my family site?

- Import first file to Family Tree Builder program: How do I import a GEDCOM in Family Tree Builder?

- Then open it in Family Tree Builder, and import second project as GEDCOM file.

- In one of the steps of the wizard you will be faced with the question of whether to import the GEDCOM as a new project, or merge it with the one that is currently open. Chose ‘Merge into project XXXX’, and they will be merged.

Click to view photo in full size

If both projects were created in Family Tree Builder software:

- Decide on what project will be used as a basis for merge.

- Open second project, and export it to GEDCOM file: How do I export a GEDCOM in Family Tree Builder?

- Then open first project in Family Tree Builder, import second project as GEDCOM file and merge it with the first one as described above.

**Before merging your trees, please backup both of your projects (using File > Back up project) so that if the merging isn’t to your liking, you can always revert back to your previous trees.

If one of the projects was created in Family Tree Builder, and second one was started online: 

- Export the online tree to the GEDCOM file.

- Then open first project in Family Tree Builder, import second project as GEDCOM file and merge it with the first one as described above.

**Before merging your trees, please backup your FTB project (using File > Back up project) so that if the merging isn’t to your liking, you can always revert back to your previous tree.

Find and delete duplicates in the merged tree:

Merging the two trees will not automatically merge people who appear in both trees. This means that you will need to detect duplicates manually. This can be done by sorting alphabetically, and then deleting them: How do I merge duplicates in my Family Tree Builder project?

Another option is using the “check for duplicates tool” by going to Tools > Check for duplicates in Family Tree Builder.

Connect people in the merged tree:

Please note, what this merge process actually does is to put both family trees in the same project. It doesn’t create connection between people in the different trees. To create connections between people in the trees, please see this FAQ post:  How can I attach / detach existing people in Family Tree Builder?

If there are similar people in the two GEDCOM files, they will remain duplicates and will not be consolidated, you will need to delete the duplicates manually.

Because of this, we don’t recommend using the merge feature if the family trees are very similar and include many of the same people. If this is the case with your family trees, you should open the most updated tree and manually add the missing records from the second tree.

Photos:

In addition, photos in the tree will not be transferred. Any photos in the GEDCOM file you merged into your main tree will have to be replaced manually.

We intend to provide more advanced features for merging GEDCOM files and consolidating duplicates, in the future.

Categories: Family Tree Builder, GEDCOM
Also available in: